The Interledger Community 🌱

Discussion on: Has anyone tried running Rafiki locally?

Collapse
radhyr profile image
Radhy Author

So I did troubleshooting myself by following clue I got from bcrypt dependency. This bug is exclusive to Mac with M1 chips and when building a Docker image.

In package.json I change bcypt version from "^5.0.1" to "5.0.0" to downgrade and lock the culprit dependency that crashes Docker. From there I run yarn rebuild and run the Docker build image again.

And there it goes 😎! I finally got Rafiki build in my machine.

Rafiki docker

But now the problem is Docker can't run the image somehow.
This is the error I got when tried running Rafiki:

Error: Failed to initialize io_uring
    at Object.Module._extensions..node (internal/modules/cjs/loader.js:1144:18)
    at Module.load (internal/modules/cjs/loader.js:950:32)
    at Function.external_module_.Module._load (/workspace/.pnp.cjs:19603:14)
    at Module.require (internal/modules/cjs/loader.js:974:19)
    at require (internal/modules/cjs/helpers.js:101:18)
    at Object.<anonymous> (/workspace/.yarn/unplugged/tigerbeetle-node-npm-0.4.1-16106fd9d1/node_modules/tigerbeetle-node/dist/index.js:4:17)
    at Module._compile (internal/modules/cjs/loader.js:1085:14)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:1114:10)
    at Module.load (internal/modules/cjs/loader.js:950:32)
    at Function.external_module_.Module._load (/workspace/.pnp.cjs:19603:14)
emergency: Failed to initialise environment.

internal/modules/cjs/loader.js:1144
  return process.dlopen(module, path.toNamespacedPath(filename));
Enter fullscreen mode Exit fullscreen mode